Page 1 of 1

Error with WshShell.Run under W2K8 R2

Posted: Sun Nov 08, 2009 12:05 am
by cal77

I've got a problem with a compiled script under Windows Server 2008 R2 (64-bit). Perhaps it's a general problem with 64-bit installations and not only in this particular OS (I just tested it with W2K8 32-bit without R2 before of the actual problem)...:

Everything is working fine, if I execute the script as a VBS-file and all the commands are going through. After compilation, everything which ist working with the "WshShell.Run" command isn't executing anymore. The script ist still working further and it's finalizing it's work - but without these lines of code... If I use the same executable on a W2K8 32-bit, everything is working fine as well...

Do you have any idea, what the problem could be and how I can solve it?

Thanks a lot for your reply!


Posted: Fri Nov 20, 2009 11:00 pm
by support
This is common issues for any 32-bit application on 64-bit Windows. The one and only solution - waiting for 64-bit version of ScriptCryptor.

Posted: Wed Dec 16, 2009 2:56 pm
by twomble
Is a 64 bit version of ScriptCryptor planed for release? Cal77, did you find a work-around for this problem? I'm working on a script that will be used in both 32 and 64 bit Windows and I use the WshShell.Run a lot in the code.

Posted: Wed Dec 16, 2009 5:43 pm
by twomble
Update... I've just installed Windows 7 64 bit and I do not have this problem. Howerver, I do have a different problem. I'm not able to read or write to the registry on a 64 bit install of Windows 7. The error message I get when using objShell.RegRead is:

Error: Invalid root in registry key

If I run the code as a vbscript, it works fine. Any ideas? I've tried to read and write to the registry using WMI and with objShell.RegRead. Both ways have problems.

Posted: Wed Dec 16, 2009 7:21 pm
by support
Read at MSDN about registry redirection and WOW64:

Posted: Wed Dec 16, 2009 8:57 pm
by twomble
Wow! Thank you very much! This has solved my problem. You guys rock! :D

Posted: Sat Feb 13, 2010 12:56 am
by cal77
btw: I just packed all the executables I need to run with the shell into the same path as the compiled VBScript-EXE - with that, it will run everything as well under 64-bit installations!

That means: It's solved for me as well!

btw2: Would it be possible, to have a better save-option, so that I can save the whole compilation project including icon, includes and file-info?

Posted: Sat Feb 13, 2010 2:08 am
by support
Yes, next version will save all optins inside script as comments.

Scriptcryptor on 64 bit Windows 7

Posted: Thu Jun 23, 2011 12:46 pm
by msacademy
I am having the same issue. The program just does nothing and ends. It works fine as a vbe or when compiled with VBSEdit. And of course it works fine with script as a vbs.


Posted: Fri Jun 24, 2011 3:43 pm
by support
VBSedit doesn't compile scripts. It's only create sfx-archive with launcher.

Posted: Wed Jul 06, 2011 5:18 pm
by Whale
I just notce it stated in vbsedit website, their new release no longer extract to temp file anymore. Correct me if I'm wrong. :?:

Posted: Wed Jul 06, 2011 8:38 pm
by support
I'll check this out.